Menu

Search

KWizCom Support Center


ERROR: It appears that you have settings that were created using an older version. In order for these settings to take effect, you will need to upgrade them first


dean
List Forms Extensions Feature

Summary

After upgrading SharePoint List Forms Extensions to a newer version, you get the following error message:

“It appears that you have settings that were created using an older version. In order for these settings to take effect, you will need to upgrade them first. To upgrade these rules please go to the product setting pages and follow the instructions there.”

Product & Version

 List forms extensions Feature v 2.2.xx (SharePoint 2007) and 12.2.xx (SharePoint 2010)

Symptoms

You get an error message at the top of your screen and your rules do not work

Reasoning

In regards to the message.  In the very old versions of List Form Extension feature we used binary format to store settings.  After version 1.2 we have found the binary mode to be very hard to manage and upgrade, so we switched to XML formatting.  During the following versions we kept code for backward compatibility with binary settings to allow smooth upgrade process.   From the released version 2.1.50 on above, our rules formatting had changed again significantly, and we did keep it backwards compatible with any version after 1.2, however settings that were created before that could not be supported anymore.  We do offer an upgrade process to settings that require each list owner to go into the settings pages and click apply to upgrade the rules for each page (Field level permissions, constraints, etc.), however we learned that in rare cases the rules are not updated accurately, and some settings may change.   For that reason we urge our customers to go in every settings page, review the upgraded settings, fix any inconsistencies and only then upgrade the rules version (This cannot be done by an automatic process).

Resolution

All you need is to go to the setting pages and click apply to re-save the settings in the new XML format for each setting ex: field level permission, groups, ect.  After doing that, you should be able to upgrade to the latest releases without problems.

 

 

 


On a scale of 1-5, please rate the helpfulness of this article


Not Helpful
Very Helpful
Optionally provide private feedback to help us improve this article...

Thank you for your feedback!


Details
Last Modified: 8 Years Ago
Last Modified By: anthony.pham
Type: ERRDOC
Article not rated yet.
Article has been viewed 1.8K times.
Options
Also In This Category